DE Normal Map Generator 1.4 Release

Announcements from the Admins.
User avatar
Dragonlord
Forum Administrator
Posts:609
Joined:Fri Jul 30, 2004 4:30 pm
Location:Switzerland
Contact:

Post by Dragonlord » Sat Jul 29, 2006 7:57 pm

your low resolusion mesh requires all materials used to have a texture assigned ( an image from disc file ). i should once add an error check there once upon time. simply make sure that all your materials there have as their first channel a texture from disc file. this is required as otherwise the script can not know the dimention of the texture for later generation.
Image
Oh to be a dragon, of silkworm size or immense...

Clean3d
First Steps
Posts:2
Joined:Sun Sep 23, 2007 1:41 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by Clean3d » Sun Sep 23, 2007 2:39 am

Hi,
I'm getting the same error, only mine complains about "degenerated edges" in every single vertex.

File links:
http://www.4shared.com/file/24840262/45 ... ed=c051951
http://www.4shared.com/file/24840261/dc ... ed=c051951
(Note: for some reason the .blend file I uploaded doesn't have subsurfing turned on for the high-res object, but I have tried exporting with it turned on, and it doesn't make a difference)

I tried the mesh-cleaning script, but it didn't remove any vertices or edges; and If it helps, I'm running UbuntuStudio with Blender 2.44, Fox 1.6, and Python 2.5.1 on an AMD64 3200+ with 1 gb. RAM and a GeForce 7300 GS with 256 mb of VRAM.

Any help would be appreciated!

User avatar
Dragonlord
Forum Administrator
Posts:609
Joined:Fri Jul 30, 2004 4:30 pm
Location:Switzerland
Contact:

Post by Dragonlord » Sun Sep 23, 2007 2:37 pm

I checked out your file. What you got has been degenerated tangents error. I then checked out the UV-Layout in DENormGen and there had been none. I then checked your .blend and noticed that you put the UV-Unwrap of your pumpkin outside the 0-1 range ( the grid on the texture ). DENormGen requires all UV coordinates to be inside this boundary. Everything outside is silently clipped to the boundary resulting in line-flat triangles. I tried out moving the UV-Layout in place and it works.
Image
Oh to be a dragon, of silkworm size or immense...

Guest
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by Guest » Sun Sep 23, 2007 8:20 pm

It works now! Thank you so much, Dragonlord! This tool is going to be so helpful! :)

Clean3d
First Steps
Posts:2
Joined:Sun Sep 23, 2007 1:41 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by Clean3d » Sun Sep 23, 2007 8:21 pm

Oops, that was me. Forgot to login... :oops:

User avatar
Dragonlord
Forum Administrator
Posts:609
Joined:Fri Jul 30, 2004 4:30 pm
Location:Switzerland
Contact:

Post by Dragonlord » Sun Sep 23, 2007 9:02 pm

:D . No problem. Glad to see it works.
Image
Oh to be a dragon, of silkworm size or immense...

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable